主页 > 互联网 >

file_get_contents无法请求https连接的解决方法

PHP.ini默认配置下,用file_get_contents读取https的链接,就会如下错误:
解决方案有3:
1.windows下的PHP,只需要到php.ini中把extension=php_openssl.dll前面的;删掉,重启服务就可以了。
2.linux下的PHP,就必须安装openssl模块,安装好了以后就可以访问了。
3.如果服务器你不能修改配置的话,那么就使用curl函数来替代file_get_contents函数